www.the351cforum.com

ALL things related to the Ford 351C
It is currently Wed Oct 18, 2017 5:04 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 40 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
PostPosted: Mon Apr 24, 2017 9:06 am 
Offline

Joined: Tue Nov 06, 2012 12:02 pm
Posts: 215
I was kind of leaning towards the transmission. From your graph. It looks like like 1st gear went how it should, and then once you hit second, the trans slipped the whole way to the stripe. Unless something broke in the converter when you shifted. All you can do is tear it apart and find whats wrong.


Top
 Profile  
 
PostPosted: Tue May 02, 2017 7:33 am 
Offline

Joined: Mon Nov 05, 2012 4:27 pm
Posts: 168
nova467spanker wrote:
Ok cool, good luck.
My buddy builds converters - bullet and all. I sent him your in car video and he said its weird cause if a converter is to loose usually there wont be any drop in rpm on the shift. He was wondering what size it is (8" or 9" or bigger) what stator is in it, what pump and the fin angle.

this is his company by the way. J.T. is his name
http://northtexasconverter.com/


The converter is a 9" as for the other info I have no clue. I did get the transmission and converter back yesterday, the transmission was fine however he changed the pump restrictor size and changed the stator in the converter. I'll get the car out on Saturday hopefully with better results, I'll keep you updated.


Top
 Profile  
 
PostPosted: Tue May 02, 2017 7:43 am 
Offline

Joined: Tue Nov 06, 2012 10:23 am
Posts: 833
Location: Texas
Sweet, can't wait to see it rip


Top
 Profile  
 
PostPosted: Mon May 08, 2017 5:11 am 
Offline

Joined: Mon Oct 29, 2012 9:05 am
Posts: 1875
Checking in for Brian....

Closer to ripping, but not quite there yet. Changed stator in the converter and it ran a 10.09 @ 137 mph this weekend....still riding the rev limiter from 1/8th mile out.

Another intake manifold gasket issue as well, which we're working on now.

Sneaking up on it...I'd like to see the car running 9.50's in a couple of weeks.

_________________
Brent Lykins, Lykins Motorsports
www.lykinsmotorsports.com
brent@lykinsmotorsports.com


Top
 Profile  
 
PostPosted: Wed May 17, 2017 5:50 am 
Offline

Joined: Mon Oct 29, 2012 9:05 am
Posts: 1875
Ok, another update....

We figured out what was going on with the intake manifold gasket: it wasn't the intake manifold gasket.

The head porter had actually broken through a couple of the ports and then epoxied back over them. The epoxy on #2 intake port broke loose and left a hole.

Brian found it when he had the intake off...just happened to be standing in the right spot to see it. Makes perfect sense to us now, it only smoked at the track at the end of a pass under a high manifold vacuum situation, when there was oil splashing around upstairs.

Brian has the head off right now and dropped it off at a local engine builder's shop to get it repaired quickly. While the head is off, he also is having the 1st gear in the PG trans changed from a 1.58:1 to a 1.8:1. That will help his 60' times and will cut the ET down as well. We noticed on the last pass that he made that it was trapping pretty high for the ET...it was a 10.09 at 137 mph. It was trying to catch up. :)

As soon as Photobucket quits being a piece of junk, I'll post pictures.

_________________
Brent Lykins, Lykins Motorsports
www.lykinsmotorsports.com
brent@lykinsmotorsports.com


Top
 Profile  
 
PostPosted: Wed May 17, 2017 5:51 am 
Offline

Joined: Mon Oct 29, 2012 9:05 am
Posts: 1875
Image[/URL]

Image[/URL]

_________________
Brent Lykins, Lykins Motorsports
www.lykinsmotorsports.com
brent@lykinsmotorsports.com


Top
 Profile  
 
PostPosted: Sun Jul 02, 2017 6:14 am 
Offline

Joined: Mon Oct 29, 2012 9:05 am
Posts: 1875
Finally making some steam and getting dialed in.

Brian ran a 9.86 @ 138 last night and backed that up with a 9.81 @ 132 with some tire shake at launch.

Still some car tuning and engine tuning left but I'm pretty pleased with it considering it's still running a 1.58 1st gear in the Powerglide. A 138 mph trap speed shows it's trying to come on pretty hard....

_________________
Brent Lykins, Lykins Motorsports
www.lykinsmotorsports.com
brent@lykinsmotorsports.com


Top
 Profile  
 
PostPosted: Mon Jul 03, 2017 6:46 pm 
Offline

Joined: Mon Nov 05, 2012 4:27 pm
Posts: 168
Here's a few videos from this weekend, I run a M/T Pro Bracket Radial, I'm still trying to see what the car likes but it definitely doesn't like 17.5 psi....

https://www.youtube.com/watch?v=PpmiMANtsRM

9.86@138

https://www.youtube.com/watch?v=nk4Fs2jGhjI

9.81@132, bounced the tire on the hit

https://www.youtube.com/watch?v=0dwDS-B ... e=youtu.be

https://www.youtube.com/watch?v=BcY1GfP ... e=youtu.be


Top
 Profile  
 
PostPosted: Mon Jul 03, 2017 8:17 pm 
Offline

Joined: Mon Oct 29, 2012 9:05 am
Posts: 1875
Brian can post the screenshot of the engine rpm vs driveshaft rpm, but we think it's still blowing through the converter and we are losing a lot of power to the ground there.

He was also short shifting at 6500 on the two 9.80 passes.

_________________
Brent Lykins, Lykins Motorsports
www.lykinsmotorsports.com
brent@lykinsmotorsports.com


Top
 Profile  
 
PostPosted: Mon Jul 03, 2017 11:30 pm 
Offline

Joined: Tue Nov 06, 2012 10:23 am
Posts: 833
Location: Texas
Thats gettin it for sure. Do you have any side videos of these runs?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 40 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group